Acc�s Natif SQL Server pour WinDev et WebDev 18

Accès Natif SQL Server pour WinDev et WebDev 18
Nous vous conseillons vivement de prendre connaissance de ce document. Il contient des informations importantes sur :

  • Installation de l'Accès Natif SQL Server pour WinDev 18 et WebDev 18
Attention : Pour installer l'Accès Natif SQL Server, vous devez posséder WinDev 18 ou WebDev 18.

  • Licence
L'utilisation de ce logiciel professionnel est soumis à l'acceptation de la licence qui l'accompagne.

PC SOFT - Décembre 2012 - WinDev 18, WebDev 18 - fichier LISEZMOI


Licence d'utilisation de l'Acc�s Natif SQL Server

Licence d'utilisation de l'Accès Natif SQL Server

Attention: En installant et en utilisant ce logiciel vous avez accepté les termes de la licence suivante :

Le CLIENT représente la personne (physique ou morale) ayant acquis une licence.

Le LOGICIEL désigne le droit d'utilisation du logiciel "Accès Natif SQL Server" acquis par le CLIENT.

1. Licence

Cette licence d'utilisation est concédée au CLIENT contre le versement d'un prix d'achat.
Ce LOGICIEL doit être utilisé en relation avec un et un seul SERVEUR DE DONNEES utilisant la base de données concernée.
Un SERVEUR DE DONNEES correspond à l'environnement dans lequel s'exécute le processus serveur de la base de données. Cet environnement peut être aussi bien physique (une unité centrale spécifique) que virtuel (une zone mémoire spécifique).
Il y a lieu d'acquérir autant de licences que de serveurs qui seront en relation avec ce LOGICIEL.
Dans le cadre d'un SERVEUR DE DONNEES virtualisé, il est nécessaire de posséder une licence du LOGICIEL par instance virtualisée.
Cette licence n'est transmise qu'après paiement intégral des droits, tels qu'indiqués au tarif le jour de l'acquisition.

2. Propriété du LOGICIEL

Ce logiciel est la propriété de PC SOFT. Le client a simplement acquis le droit d'utiliser ce LOGICIEL.

3. Copie de sauvegarde

Le CLIENT est autorisé à effectuer une seule copie de sauvegarde du CD et/ou disquettes composant ce LOGICIEL.
La duplication de la documentation, en totalité ou en partie, est strictement interdite.

4. Utilisation

Le CLIENT doit utiliser le LOGICIEL pour l'usage pour lequel il est vendu. Il est interdit de modifier ou tenter de modifier ce LOGICIEL, de désassembler ou tenter de désassembler ce LOGICIEL. Il est interdit d'enlever ou de tenter d'enlever les mentions de copyright pouvant apparaître et/ou étant contenues dans le LOGICIEL.
La location ou le prêt de ce LOGICIEL est interdit.

5. Absence de responsabilité

Le LOGICIEL et la documentation qui l'accompagne sont vendus en l'état, SANS AUCUNE GARANTIE D'AUCUNE SORTE. PC SOFT ne saurait être tenu pour responsable pour tout dommage de quelque nature que ce soit, et en particulier en cas de perte ou détérioration des données, en cas de perte financière, en cas de perte d'exploitation, en cas de divergence des informations contenues dans la documentation avec le comportement du LOGICIEL, en cas de comportement du LOGICIEL différent de celui attendu. Le CLIENT est seul et unique responsable du fonctionnement et du support des programmes qu'il aura réalisé avec le LOGICIEL.

6. Garantie

Si les disquettes et/ou le CD de support du LOGICIEL venaient à être détériorés, le CLIENT pourrait se procurer auprès de PC SOFT un nouveau jeu de disquettes et/ou un nouveau CD, sous réserve de fournir lors de sa demande les disquettes et/ou le CD détériorés.La fourniture du ou des nouveaux éléments sera facturée.

Si les disquettes et/ou le CD se détériorent dans les 3 mois suivant son achat, PC SOFT effectuera le remplacement à ses frais, hormis les frais de port aller et retour. Les colis ne seront acceptés que s'ils sont livrés en port payé et exempts de tous droits à payer. Le port de retour sera facturé; expédition rapide avec preuve d'arrivée à destination. Cette garantie ne sera PAS appliquée si la détérioration provient d'un accident ou d'une mauvaise utilisation.

Acceptation de la licence :

Le fait de conserver et d'utiliser ce logiciel indique la compréhension et l'acceptation des termes de cette licence.

Ce contrat ne peut pas être modifié, sauf par un courrier original paraphé de la direction générale de PC SOFT.

Ce contrat de licence est régi par le droit français; tout litige qui pourrait en résulter sera de la compétence exclusive des tribunaux du siège social de PC SOFT.

PC SOFT,
3, rue de Puech Villa
BP 44 408
34197 Montpellier Cedex 5

France

Retour au sommaire


Installation de l'Acc�s Natif SQL Server pour WinDev 18 et WebDev 18

Installation de l'Accès Natif SQL Server pour WinDev 18 et WebDev 18
Pour utiliser ce CD ROM, veuillez lancer le programme MENU.EXE présent à la racine du CD.

Depuis ce programme, vous pourrez installer l'Accès Natif SQL Server.

L'Accès Natif SQL Server peut être installé dans l'un des deux modes d'utilisation suivants :

  • Accès Natif SQL Server via client SQLnCli. Version conseillée.
    SQLnCli est la couche client livrée en standard à partir de SQL Server 2005.
    Dans ce mode, l'accès natif peut également utiliser la couche client SQLOLEDB proposée par défaut à partir de Windows XP.
  • Accès Natif SQL Server via client DB-Library. Version conservée par compatibilité.
    DB-Library est la couche client livrée avec les versions de SQL Server antérieures à 2005.

Attention : Pour installer cet Accès Natif SQL Server, vous devez posséder WinDev 18 ou WebDev 18.

Avant d'installer l'Accès Natif SQL Server, vérifiez qu'aucun autre programme ne soit actif (au besoin redémarrez la machine), puis lancez l'installation.

Opérations effectuées lors de l'installation

  • L'installation de l'Accès Natif SQL Server va installer les modules nécessaires dans le répertoire d'installation de WinDev 18 ou WebDev 18.

  • Les fichiers installés sont les suivants :

wdxxxsqlserver.dll DLL de l'Accès Natif SQL Server via SQLnCli (32 bits).

Remarque : Cette DLL n'est installée que si c'est le mode Accès Natif SQL Server via client SQLnCli qui a été choisi lors de l'installation.
wdxxxsqlserver64.dll DLL de l'Accès Natif SQL Server via SQLnCli (64 bits).

Remarque : Cette DLL n'est installée que si c'est le mode Accès Natif SQL Server via client SQLnCli qui a été choisi lors de l'installation.
wdxxxsqs.dll DLL de l'Accès Natif SQL Server via DB-Library.

Remarque : Cette DLL n'est installée que si c'est le mode Accès Natif SQL Server via client DB-Library qui a été choisi lors de l'installation.
WDSQSINS.EXE Programme de paramétrage des connexions à une base SQL Server (conservé pour compatibilité).
Les fichiers suivants (librairies nécessaires à l'exécution de WDSQSINS.EXE) sont présents dans le répertoire de l'exécutable :
wdorahf.dll, wdorahtml.dll, wdoraimg2.dll, wdoraimg.dll, wdoramat.dll, wdoraobj.dll, wdorapdf.dll, wdorapnt.dll, wdoraprn.dll, wdorartf.dll, wdorastd.dll, wdoravm.dll, wdoraxls.dll, wdoraxml.dll.
WDSQLServer.CHM | Aide en ligne locale de l'Accès Natif SQL Server. Cette aide est nécessaire uniquement si WDSQSINS est installé dans un répertoire différent de celui de WinDev, WinDev Mobile ou WebDev.
Licence_AccesNatif_SQLServer.chm | Licence du produit.

Conseil : En cas de problèmes lors de l'utilisation du menu MENU.EXE, vous pouvez lancer directement l'installation par le programme INSTALL.EXE présent dans le sous-répertoire SQS18.

Remarques :

  • Ce CD-Rom contient également les Accès Natifs SQL Server via DB-Library pour les versions précédentes de WinDev et les versions précédentes de WebDev.
  • L'installation de l'Accès Natif SQL Server pour WinDev 5.5 et WebDev 1.5 nécessite un numéro de série spécifique. Pour plus de détails, contactez le service commercial de PC SOFT.

Retour au sommaire