Native SQL Server Access for WinDev and WebDev 18

We recommend that you read this document. It contains important information about:

  • Installing the Native SQL Server Access for WinDev 18 and WebDev 18
Caution: To install the Native SQL Server Access, you must own WinDev 18 or WebDev 18.

  • License
The use of this professional software is subject to acceptance of the license agreement.

PC SOFT - December 2012 - WinDev 18, WebDev 18 - README


License agreement for the Native SQL Server Access

Caution: By installing and using this software, you have agreed with the terms of the license agreement:

CUSTOMER shall mean the original customer (either individual or company) who purchased a license.

SOFTWARE shall mean the right to use "Native SQL Server Access" purchased by the CUSTOMER.

1. License

This user license is granted to the CUSTOMER in exchange for the payment of a purchase price.
This SOFTWARE shall be used with one, and only one, DATA SERVER that uses the given database.
A DATA SERVER corresponds to the environment in which the server process of the database is run. This environment can be physical (a specific CPU) or virtual (a specific memory zone).
The CUSTOMER shall purchase as many licenses as the number of servers that will be in relation with this SOFTWARE.
For a virtualized DATA SERVER, a SOFTWARE license is required for each virtualized instance.
This license is granted only after full payment of rights as indicated on the price list on the day of the purchase.

2. SOFTWARE ownership

This software is the sole and exclusive property of PC SOFT. The customer has only purchased the right to use the SOFTWARE.

3. Backup copy

The CUSTOMER agrees to make no more than one backup copy of the CD and/or diskettes supplied with the SOFTWARE.
Reproducing the documentation, in part or in full, is strictly forbidden.

4. Use

The CUSTOMER agrees to use the SOFTWARE only for the purpose for which it is intended. The CUSTOMER shall not modify, or try to modify, nor disassemble, or try to disassemble this SOFTWARE. The CUSTOMER shall not remove (or try to remove) the copyright mentions that may be displayed and/or included in the SOFTWARE.
The SOFTWARE shall not be rented, leased or shared.

5. Liability

The SOFTWARE and the documentation are sold as is, WITHOUT ANY WARRANTY as to performance, merchantability or fitness for any particular purpose. PC SOFT shall not be liable for damages of any nature whatsoever, including data loss or deterioration, financial or operational loss, discrepancies between information supplied in the documentation and SOFTWARE behavior, in case the SOFTWARE behaves differently than expected. The entire risk as to the results and performance of programs created with the SOFTWARE is assumed by the CUSTOMER.

6. Warranty

If the diskettes and/or the CD on which the SOFTWARE is stored become defective, the CUSTOMER may obtain from PC SOFT a replacement set of diskettes and/or a new CD, if the CUSTOMER supplies the defective diskettes and/or CD along with the replacement request.The replacement items will be invoiced.

If the diskettes and/or CD become defective within 3 months of the original purchase, PC SOFT will replace them without charge, excluding shipping costs. Parcels will be accepted only if delivered postage paid and tax-free. The return postage will be invoiced ; express shipping and proof of delivery. This warranty shall not apply if the items become defective due to an accident or mishandling.

Acceptance of the license:

By installing and using this software, you have agreed with the terms of license agreement.

This license shall not be modified by the representations of anyone unless a written amendment has been signed by a corporate officer of PC SOFT.

This license agreement is governed by French Laws; any disputes that may arise are to be settled within the jurisdiction of the courts where PC SOFT has its headquarters.

PC SOFT,
3, rue de Puech Villa
BP 44 408
34197 Montpellier Cedex 5

France

Back to summary


Installing the Native SQL Server Access for WinDev 18 and WebDev 18

To use this CD-ROM, start MENU.EXE found at the root of the CD.

This program enables you to install the Native SQL Server Access.

The Native SQL Server Access can be installed in one of two following use modes:

  • Native SQL Server Access via SQLnCli client. Recommended version.
    SQLnCli is the client layer supplied from SQL Server 2005.
    In this mode, the native access can also use the SQLOLEDB client layer proposed by default since Windows XP.
  • Native SQL Server Access via DB-Library client. Version kept for backward compatibility.
    DB-Library is the client layer supplied with the versions of SQL Server earlier than 2005.

Caution: To install this Native SQL Server Access, you must own WinDev 18 or WebDev 18.

Before installing the Native SQL Server Access, check whether no other program is active (reboot the computer if necessary) and start the setup.

Operations performed during the setup

  • The modules required by the Native SQL Server Access will be installed in the setup directory of WinDev 18 or WebDev 18.

  • The following files will be installed:

wdxxxsqlserver.dll DLL of the Native SQL Server Access via SQLnCli (32 bits).

Note: This DLL is installed only if the Native SQL Server Access via SQLnCli client mode was chosen during the setup.
wdxxxsqlserver64.dll DLL of the Native SQL Server Access via SQLnCli (64 bits).

Note: This DLL is installed only if the Native SQL Server Access via SQLnCli client mode was chosen during the setup.
wdxxxsqs.dll DLL of the Native SQL Server Access via DB-Library.

Note: This DLL is installed only if the Native SQL Server Access via DB-Library client mode was chosen during the setup.
WDSQSINS.EXE Program for configuring the connections to a SQL Server database (kept for backward compatibility).
The following files (libraries required to run WDSQSINS.EXE) are found in the directory of the executable:
wdorahf.dll, wdorahtml.dll, wdoraimg2.dll, wdoraimg.dll, wdoramat.dll, wdoraobj.dll, wdorapdf.dll, wdorapnt.dll, wdoraprn.dll, wdorartf.dll, wdorastd.dll, wdoravm.dll, wdoraxls.dll, wdoraxml.dll.
WDSQLServerUS.CHM | Online help for the Native SQL Server Access. This help is required only if WDSQSINS is installed in a directory different from the one of WinDev, WinDev Mobile or WebDev.
License_SQLServer_NativeAccess.chm | License agreement for the product.

Tip: If problems occur when using MENU.EXE, the setup can be directly run from INSTALL.EXE found in the SQS18 sub-directory.

Notes:

  • This CD also contains the Native SQL Server Accesses via DB-Library for the earlier versions of WinDev and for the earlier versions of WebDev.
  • A specific serial number is required when installing the Native SQL Server Access for WinDev 5.5 and WebDev 1.5. Contact PC SOFT Sales Department for more details.

Back to summary